Listary 6 Beta 🎉


#83

Hello,
just installed the latest beta and have now a jumping Listery popup.
When I open the Popup window the content jumps up an down and a littel black arrow on the top is shown.
It seems to mee that I have to much entries and so I´m over a max. high of the popup window.
6.0.1.7 worked fine but xxx.8 makes problems.
Also I can only open the popup window only one time with middle mouse click.
Another problem is that the middle mouse click does´nt work in my file explorer (XYplorer). I have to do that with a keyboard short cut.

Thanks for a soon help.

Cheers
gieri

Add: the submenus does´nt appear near the popup window but in the upper left corner of my display. But only that scrolling arrows. Reset the launcher position does´nt helped.shaking

Addd: I find out what the reason for the flick and shaking of the popup window… if you have more than 20 entries (include the separator lines), the window seems to small and shakes between the scrolling arrows up and down.


#84

Listary always seems to work on the first lister in dopus. So when starting a WSL from the second lister, Listary opens up WSL in the directory of the first lister. The same happens when searching files


#85

I have 3 monitors running, 2 external and one is the laptop driving them. If I’m focused on one of the external monitors and hit ctrl-ctrl Listary only ever opens on one of them. If I’m focused on the main laptop screen Listary does not show up. Listary does load however, if I type and press enter a folder loads…So listary has just opened off screen somehow. The laptop screen is a higher resolution than the monitors, if that matters.

Thanks!

Edit: SOLVED. Went into Settings > General > Reset Launcher Position. It’s showing up again, and on whichever monitor I’m focused on. Interesting though, if I drag the Listary popup a tiny bit, next time it pops up it’s only in that position no matter the monitor i’m focused on.


#86

Thanks. Currently running with this logging enabled, so I’ll upload when I have a log file capturing the freeze. It is certainly slower now, assume that is the logging.

To answer your question, when it hangs up I can right click to see the menu from the tray icon, but nothing is selectable.


#87

@Channing
I have 2 Problems with Listary 6.0.1.8.

  • First sometimes Listary does not show anything at all. See screenshot below. It works however, meaning that i can type characters and open apps. I just don’t see anything at all. Sometimes the bug dissappears itself without me doing anything apart from trying it again. But sometimes it takes a long time until it works. Unfornately i wasn’t able to determine any logic when the bug appears and when it resolves itself again.

  • The second problem is that it seems the working directoy of executed exe files has changed since Listary 5. The reason why i believe that is because i have an exe file in some folder which i can execute via listary(not in explorer mode, just open listary on desktop enter the program name and hit enter). In Listary 5 everything was fine, in Listary 6 the exe behaves like it was executed not in the folder it is saved, but instead like in some other folder (windows/system32 i think was the working directory when i printed it out via some bat command). The program then shuts down with a message that i cannot find another file it needs, which is in the same folder. Again opening the program manually works. Also in listary 5 it worked. Just in Listary 6 it does not work anymore.

#88

For your second problem, maybe you can create a custom command (go to Features --> Commands in the option settings) to see if it works.


#89

OK, I’ll find a way to allow using a keyword that is not in the folder name.


#90

@gieri Please update to the latest version and test.
@jatou Complete 3rd-party file manager support will be available soon.


#91
  1. Check if it’s the DPI setting issue.
  1. As @jdhao mentioned, you need to set the working directory manually.

#92

I use StrokesPlus. It is great.


#93

Quick Switch (Ctrl + G) is not working here… (I think since the first beta release).

Windows 10 64-bit.


#94

i didn’t changed anything there. also setting the working directoy for every program that has problems seems counterintuitive. why the change between listary 5 and 6? windows also doesn’t enforce a different working directory when i execute a program via the quick search.


#95

Which file manager are you using? Note that 3rd-party file manager support hasn’t been added yet.


#96

There is no change at all. The working directory is Listary’s installation folder in both 5 and 6. My guess is that you did manually set the working directory in Listary 5, but that setting was not automatically imported to version 6.

EDITED: I just checked. Importing working directory was added in 6.0.1.7. So if your setting was imported by a previous beta, You need to set it again. Sorry for the inconvenience.


#97

Quick Switch (Ctrl + G) works fine here in the actual beta
under Windows 10 x64 version 1809


#98

@Channing, interesting to note that with the log running and everything slowed down that I didn’t get a failure at all yesterday, which is a first.


#99

Can you please stop adding that annoying app icon on my desktop with every update?


#100

Windows Explorer, native.


#101

Can you type directly to search in Explorer?


#102

Well, it follows your first time installation settings. I’ve just changed the default.