Listary 6 Beta 🎉


OK, I’ll consider that option.


Items in Actions can be rearranged with the up and down arrow buttons.
Please integrate this with:

  • Web Search
  • Commands
  • Menu

Use drag and drop to reorganize menus.

Web Search and Commands do not have order. In search results, they are sorted by relevance and your previous open history.

1 Like

Use drag and drop to reorganize menus.

I didn’t know about this. Thanks!

Regarding Web Search, it would be handy if they could be sorted according to relevance:
– search engines:
– videos:
– shopping:
– icons:
Font Awesome
Material Design


That’s reasonable. I’ll consider it.

1 Like

Where is the actual config file stored?
I tried running Listary from a thumb drive on another PC but my custom web searches, commands, and custom actions wouldn’t appear.

Specifying which folder to install Listary settings doesn’t contain anything either.


The default folder is C:\Users\YOUR_NAME\AppData\Roaming\Listary\UserProfile.

You can change the settings folder after installing Listary:

  1. Exit Listary.
  2. Open the containing folder of Listary.exe. Find or create a DataFolderRedirection.txt .
  3. Edit its contents to the path of your settings folder. Relative paths (e.g. . and ..\..\ABC) are also supported.

Finally got it working


This is my Listary setting.
I’ve done a couple of rebuilds, but there is no difference.
The H drive is not in the Index, and there is no H drive on the PC connection drive.
However, the H drive is still appearing in the Listary search, and it will not disappear for quite some time.


There could be several reasons for it:

  1. You’ve opened the path via Listary before, and it was added to History. At the moment there is no way to clean history manually in the beta version. It’ll be added soon. However, if the path is invalid, it will be removed automatically later.

  2. Check if you’ve added the path as a favorite folder or search filter.


For some reason Listary’s popup would not work on all Open or Save As dialogs.
Instead of changing the dialog’s location to the selected Favorite menu, the Favorite gets opened in the default Open with folder program.

These are some of the programs where the popup doesn’t work on:

  • Visual Studio Code
  • Sublime Text

Programs where the popup behaves as it should:

  • Google Chrome
  • Photoshop

I understood your explain. But It seems not to be working auto deletion for history data. There’s no favorite and filters about H drive. I have found for path settings about H drive, but There’s no any other settings for H drive. Can I init whole data file?



  1. Exit Listary.
  2. Delete C:\Users\YOUR_USER_NAME\AppData\Roaming\Listary\UserProfile

I just tested it and Listary worked with VS Code.

Is this problem always reproducible on your system? Are you running VS Code as admin?


I just wanted to add a humble and very kind reminder, because I will be, so to speak, messed up and amputated :grimacing: without Listary support for Office 2003 in the future :pray: :relaxed: :pray:


Yes, I run VS Code as admin. Most of the programs I use (including Listary itself) are run as admin.
Chrome and Photoshop aren’t, which is maybe why Listary works with their dialogs.

Tried a system restart and run VS code without admin rights and Listary showed up when I tried to open a folder.

Hope Listary could be patched to work on programs that have this setup. :grinning:


You are alone which such an unsecure behaviour
and no tool needs to support that.
There is never ever a reason to work like that in current Windows version.


This is so cool.
Will a pro-license for 5 also work for 6 or do I have to buy a new license?


Running the latest beta version with Office 2016. MS Word 2016 keeps crashing. Any suggestion? Error in event log:

Faulting application name: WINWORD.EXE, version: 16.0.8431.2110, time stamp: 0x59fbc529
Faulting module name: ListaryHook32-, version:, time stamp: 0x5c5c4723
Exception code: 0xc00001a5
Fault offset: 0x00023050
Faulting process id: 0x1260
Faulting application start time: 0x01d4e594e26f0e4a
Faulting application path: C:\Program Files (x86)\Microsoft Office\Root\Office16\WINWORD.EXE
Faulting module path: ListaryHook32-
Report Id: 968fd212-225b-4ff7-9233-fec056479328
Faulting package full name:


Hi @Channing, I think I’ve found two bugs regarding to the extension system.

First (minor): When calling the Listary input (Double Ctrl) shortly after starting listary, it won’t detect my configured extension keywords. Only when closing the box (Esc) and Re-opening it again (Double Ctrl), the keywords will be detected properly.

Second (major): Extensions stop working after resuming Windows from hibernate / sleep. I can still search for keywords, but all node extensions return “No results found”. I assume it’s some kind of networking issue. Restarting Listary resolves it.