Listary 6 Beta 🎉


#285

I like it


#286

I know you have a lot on your plate but when you are able to implement selecting multiple items from the search results, take a look at how it’s done in Alfred (for Mac) in this video (at 8:40’)


#287

I am loving the beta right now. However, I do have a complaint. There seems to be a noticeable lag between when I press my hotkey (Alt+Space) and Listary showing up. It’s a lag of maybe 0.5 to 1 seconds. It’s not a huge problem, but sometimes I call up Listary and begin typing, only to find that I’m typing into a document I’m working on because Listary didn’t show up right away.

If you can fix this problem, I would really appreciate it.


#288

You can add a Web Search to launch websites.

input web github.com:
image

But in this case, the url cannot contain the ‘http://’ part of the prefix.

Web Search

  • Url : http://{query}
    input web github.com , open http://github.com
    input web http://github.com , err!

  • Url : https://{query}
    input web github.com , open https://github.com
    input web http://github.com , err!


The above method will automatically open with the default browser, but not for all situations. You can add a command to open any URL using the specified browser.

  • Input web github.com , open http://github.com
  • Input web http://github.com , open http://github.com
  • Input web https://github.com , open https://github.com

#289

Thanks for the suggestion. Multiple selection support has been planned for version 6.1.


#290

Thank you for your feedback.

Could you share the log file to help me address the issue?

  1. Exit Listary.
  2. Run Listary with parameters via the command line. Change the path if you’ve changed the installation folder:
    "C:\Program Files\Listary\Listary.exe" --log-level=0
  3. Activate Listary with Alt+Space, the lag should happen as you described. Send the following file to support@listary.com or upload it here:
    C:\Users\<Your user name>\AppData\Roaming\Listary\UserProfile\Cache\<Your computer name>\ListaryLog.txt

#291

Yes PLEASE PLEASE !

Its odd because sometimes Listary works in the beginning with Word 2003, and then at some point just stops!

Thanks heaps for having a look into this!

David


#292

Okay, that’s strange. Because when I updated from 5 to 6, Listary didn’t pick up the NAS index.
And clicking on re-index didn’t do anything. I’ll check again…


#293

I used Google Drive as drive H. I changed the drive letter to drive G. The listary still holds the index for drive H and appears in the search results. Rebuild does not disappear.


#294

Did you add H: to Listary’s Index settings?

Note that if you’ve opened some files on H: using Listary before, they may be added to Listary’s history. They will be removed automatically the next time you search after removing H:.


#295

Hi Channing, most of the time, I’ve got the same “laggish” experience as @jbryan does. It’s about 0,5-1,5 seconds delay until the search input pops up, which disturbs one’s flow quite enough to be annoying.

I’ve enabled the debug log as you suggested, but the only relevant entries are:

2019-02-26 21:35:44.983 [5][Error] [?] FileDB root not added via FileDBInit!
2019-02-26 21:35:44.983 [5][Error] [?] First user visible root [S:] 

Maybe it’s because of my addional added root S:? I’ll try without and reply here.


#296

Hi,

  1. Logging doesn’t seem to be enabled on your system. It should output hundreds of entries when working. Make sure you’re using 6.0.2.12 and try again.
  2. The 2 error entries about S: are ignorable. They’re unlikely to be the cause of the delay.

#297

Well, I tried the latest Listary Beta and no luck with the network drives.
It’s listed in the index menu and at the bottom it says Last updated: never.
When I click on “update now”, a blue pop up appears for like 4 seconds and then it disappears.
Does that mean it’s doing something in the background?

EDIT: ahhh, it worked. It took some time and was doing stuff in the background. Maybe some progress indication would be great.


#298

@Channing you can just replace , -> . before feeding it into calculator.

Also unfortunately something like: 5--3 doesn’t work. I’d expect to get 8 BUT 5- -3 does work. I’ve had to patch Wox to make a simple fix of input.Replace("--", "- -"); to make this work. Could you do the same?
Reason is that on laptop it’s very easy to press -- but hard to press + as it requires shift key so using -- is a very convenient hack. Thanks for all your work!


#299

Listary 6 doesn’t seem to be searching in lists such as Task Manager > Details or Windows Services list. Is there a plan to bring this back?


#300

Hi,

, has already been supported for specific cultures. -- is a really rare need. I’ll consider it.

There is no plan to bring Task Manager list search back at the moment, but there will be alternatives (e.g. process management extension).


#301

That’s really sad. After searching for files, searching lists (Task Manager, Services, etc) was the second most important feature.


#302

Listary really needs a ctrl-z support. This is especially evident when using calculator. You type some complex formula, remember the answer, start doing something else, want to re-check what the answer was: poof, no way to get this info back from Listary. Launchy has a great ctrl-z implementation (Wox’s sucks).


#303

Simply press Up arrow after double Ctrl, assuming that you’ve pressed Enter to copy your previous calculator result to clipboard.


#304

The usual flow is to click outside or press escape to close the launcher. Also I’ve checked that when you press up to see previous entry you can’t ctrl+z it, it only works while editing for the first time before enter. This is essential when doing calculations where you are testing several assumptions and continuously editing, undoing, changing the formula.