Windows/Apps being openend in background/Out of focus

For eg. if i type notepad.exe and press enter,a new notepad opens but the window is opened in the background,behind the current window. I have to click on the window, or press alt+enter and select notepad before I start typing.

compare this to win key. when i type notepad and press enter it opens notepad in the foreground and the cursor is blinking and i can just start typing.

This happens for all apps/windows.

I use listray porttable latest version on win 7 x64 home basic

1 Like

Thanks for your feedback. Sorry that I’m not able to reproduce this bug locally. I’ve made some changes to the window opening behaviours in the new version. Hopefully they will fix this.

I have the same problem. It started a while ago.

Listary Pro, 4.23.1728, Win 7 Ultimate SP1, x64.

Yeah, just fixed it.

I notice another case like this:

  • On a explorer window, type a.txt and then press the right arrow key to show Listary menu
  • scroll down the menu and find Edit, which is below Open, and press Enter key
  • an editor program like notepad.exe is run, BUT in background

Is it needed to re-focus the explorer window on hiding the Listary toolbar?

Thank you for reporting. I’ve just fixed this bug.

Thank you! Do you have an idea when the fix will be available?

It’ll be released this month.

I recently bought Listary & am seeing this behavior. Please let me know if there’s any info I can share that would help diagnose the issue.

Listary Pro 5.00.2406
Windows 10 Pro x64 + Anniversary Update

Hi, can you provide the following information?

  1. Are you running Listary as admin?
  2. Do you mean that when you use Listary to launch an application, the app is opened in background? Or does this happen when you use Listary to open a document file?
  1. Yes, in Listary Options the “Run as administrator” checkbox is checked.
  2. Apps & documents both open in the background.

Unchecking “Run as administrator” and restarting Listary should fix the issue.

1 Like

Yep, that fixed it. Thanks!

I could not find this option. Can you say how to access the administrator run option. This just started happening after I upgraded to Windows 11 V 22H2. I’m thinking that option has now been removed from the Options.

After more testing, I discovered this is only happening on a couple of programs. I haven’t duplicated yet, except that Quickbooks opens out of focus when launched through Listary. Not only that, Quickbooks moves behind your other windows again, after the password is entered.