Unable to add new program to Listary

I had been using Listary basic for some time but had to re-install my system. I now find that I cannot add the writer and calc programs in Libre Office to Listary. I tried to add the exe files in options but they added but then disappeared after I saved them. I also have been unable to use the “Add Application to support widget” as when I try to add the application the OK button is greyed out.

Hello IanRH,

Could you please tell me the reason that you’d like to add these programs from Libre Office to Listary? Normally you don’t need to do this manually. Listary will take care of it.

This is what I don’t understand. Listary does not appear on the Save As Dialog in Libre Office 3.5.5 so I was trying to add it using the ways I described previously.

I did not describe the problem clearly but jumped to the ways I tried to solve the problem.

Listary does appear on my pdf reader and on my txt file reader so I think the problem is connected with Libre Office.


Hello Ian,

Listary supports Libre Office 3.5.5. According to your description, it seems that your Libre Office is running as administrator. Could you please check this? A simple restart may also solve the problem.

I have restarted the computer but Libre Office still does not open Listary when I try to Save As.

I do not know whether it is running as Administrator and cannot find any references on how to check this.

I am afraid my lack of knowledge is showing.

Apreciate the assistance

Hello IanRH,

Sorry for the inconvenience. I’ll look more into this.

Have you had any success in making Listary work with Libre Office?

Helllo IanRH,

I’m sorry for the delay in responding.

It’s very weird that Listary works fine with LibreOffice on all my testing machines (both Windows Xp and Windows 7). Here are some screenshots:
Windows 7

Windows Xp (Japanese version of Listary)

Could you please provide the following information?

  1. Your Windows version.
  2. Is there any difference between your system and the screenshots above?
  3. Does Listary appear on Open file dialogs?

Thank you!

I am using Windows 7 Home Premium

Listary does not appear on the LibreOffice Save AS dialogs but works on all other programs.

I think it is because I have updated my copy to LibreOffice
Build ID: 7122e39-92ed229-498d286-15e43b4-d70da21

and this has a different method for Save As

Your pictures are what I used to see, I did take a screen shot but my competence is not up to adding it to this message.

Hello IanRH,

Thank you for the information. Does Listary appear on the Open file dialog of LibreOffice?

No it does not

Please exit Listary first, and then right click on Listary’s shortcuts in your Start menu, and then select Run as administrator. See if it works now.

No, this does not solve the problem.

It does appear to me that Libre-Office have changed the way in which you navigate from one directory to another. If I click and hold on the ‘Up One Level’ icon I get a dialog which shows the available upwards directories. In the case of My Documents this means firstly my Users directory, secondly my C directory.

Hope this explanation assists

Have you managed to replicate the problem?

Sorry that I still can’t reproduce the bug :frowning:

Mea Culpa time. The following is what I posted at Libre Office and the answer which solved the problem.

I apologise for wasting the valuable time of the developer

I upgraded to from I think 3.5.5 but found that a very useful program that I use Listary (http://www.listary.com) no longer works and the developer cannot replicate the problem. It seems to me that when using ‘Save As’ and other similar dialogues that LibreOffice has changed the navigation method. I noticed that now a list of the upstream folders appears when I hover and left click over the ‘Up one folder’ icon. This does make navigation easier but is not as easy as using Listary. I appreciate that this for LibreOffice is an improvement but if you can point me to where I can find out how the ‘Save As’ system has cahnged I can then inform the developer and he may be able to upgrade his program. Any advice appreciated.

It appears that you have somehow changed from the Windows standard dialogs to LibreOffice’s own dialogs.

To change back go to Tools, Options, LibreOffice, General and uncheck the option under Open/Save dialogs: Use LibreOffice dialogs.

This works and is posted so as to assist others.


Thank you for the information! Glad it works now.