Some explorer related features suddenly stop working

I am using Listary portable (version 3.51.819) on a Windows XP Pro SP3 (32bit). Last week I installed Listary and it was working very well, but all the sudden some features stop working:

  1. “Double click in empty area” does not active Listary anymore (although I did enable “Double click” in “Keyboard and Mouse”;
  2. The Global “Show popup menu” hotkey still brings up Listary menu, however, it seems that Listary has totally detached from any currently running explorer:
    a. clicking on any folder from Listary’s popup menu (either under Favorite or Recent) does not switch current running explorer to that folder (seems like nothing happens after clicking a folder);
    b. “Currently Opened Folders” always shows “None”;
    c. Any current folder related Smart command, like “Command Prompt”, runs from Listary’s own folder, not from current folder of focused explorer;
    d. When typing in explorer, the quick filter list does not popup and I am stuck in explorer’s own type-and-find feature.

Note that if there’s no explorer running, click on a folder from popup menu does bring up a explorer with correct folder, however, this new explorer is still detached from Listary (“Double click” does not work, cannot switch folders, no filter list, etc.)

Switching directory in Listary’s toolbar still works for Open/Save file dialog.

It could be some options I changed but I went through Listary’s “Options” and did not find what option(s) I changed can affect this issue.

I also tried exit Listary, kill explorer, reboot system, no lucks.

On the other hand, all my Windows 7 systems (all 64bit) are working without this issue.

Any ideas? Thanks.

Hello cameos,

Please go to Listary Options > Applications and find Explorer (C:\Windows\Explorer.exe) in the top list, check if “Enable Listary for this application” (between the two lists) is checked.


I cannot add explorer.exe as an application: I add it and click OK, then when I go back to Options->Applications, the line of c:\windows\explorer.exe is not there anymore.


OK, I quit Listary, manually edited Config.xml and changed one application to c:\windows\explorer.exe, when I started Listary, I checked Options->Applications, c:\Windows\explorer.exe is there, with “enable listary for this application”.

However, the explorer window still has the same problem (“double click” does nothing, typing uses explorer’s own type-and-find, etc.)

Hello cameos,

That’s really weird, there should be an explorer.exe entry there by default… Could you please do a case insensitive search for “explorer.exe” in Config.xml and set “ShowToolbar” to “True”? It should be like:


You can also try the following steps to see if it’s a problem of your configurations or Listary itself:

  1. Quit Listary and rename Config.xml to something like ConfigBackup.xml
  2. Start Listary. This would be a clean start, please try if Listary works in Explorer now.


Yes I checked my Config.xml it has the Explorer.exe part, the only differences are I have different RecentFile/RecentFolder items.

I also tried restart Listary from a. no Config.xml and b. Config.xml in (which is blank), I then saw the problem that

  1. Explorer.exe was not in Options/Applicationsand
  2. I could not add Explorer.exe in Options/Applicaitons (it keeps disappearing)

For you to investigate this issue, I have my Config.xml uploaded on internet:

Config.xml.bad (my old Config.xml, Explorer.exe in Applications was manually added by me in editor):

Config.xml.newly.generated.from.blank (newly generated Config.xml from a blank Config.xml, I could not add Explorer.exe in Options/Applications):

My Windows explorer.exe’s version: 6.00.2900.5512 (xpsp 080413-2105)

One thing I want to mention is, I am not using Windows Explorer as the default shell, I am using emergeDesktop ( with a standalone explorer.exe, this configurations worked last week, and my running explorer seems working with other keyboard/mouse events (left click, right click on items, right click pop-menu, etc.)

Hello Cameos,

Thank you very much for the information. The xml files look OK.

2. I could not add Explorer.exe in Options/Applicaitons (it keeps disappearing)
This is also a designed behavior. If you keep all settings of an application default (e.g. set "Enable Listary for this application" to true), the settings won't be saved.

Sorry that I still have no clue for this bug currently. I’ll look more into it.

Thanks, Channing!