Q-Dir starts directories in new instances, when using Listary [Solved]


I’m using Q-Dir as a default file manager. Listary Works perfect with it, except for one issue: Although Q-Dir is set to start any directory in the same instance (which actually works), when I use Listary it always starts in another one. I think I shoud add some command characters at “%1” in the settings of parameter. Any help?


If you manually construct a command line like C:\path_to_qdir.exe "D:\Folder to open"
and paste it to the Win+R Run dialog, does it open in an existing Q-Dir window?


No. It opens a new Q-Dir window.


Good news! I asked this question in another forum, and they helped me to solve this problem. The parameter one has to set when using Q-Dir as default file manager is: /e>%1>

Notice that there is no “”

I’m happy again with Listary and Q-Dir (and now, I’m happy too with the freeware I found in the forum where I asked my question, which by the way I recomend it too. It’s called “Everything” and it’s a very powerful file searching app: https://www.voidtools.com/forum/viewtopic.php?f=5&t=6183&p=20830#p20830)



Thanks for the info. I’ll add a template for Q-Dir setting in Listary Options.


Hello Allekz, could I please ask you to specify the exact windows command ? I’ve tried this:

c:>"C:\Program Files\Q-Dir\Q-Dir.exe" /e>%1>D:\my_dir

but I’m obviously misunderstanding your solution. The Q-Dir “Open in New Tab, in the running instance” doesn’t seem to work.
Thank you


What worked for me was just the parameter: /e>%1> (No path or directory)
The only path entered was the asked one by LIstary as “Default file manager”, in my case: “C:\Program Files\Q-Dir\Q-Dir.exe”.

Actually I got some troubles when I updated my Qdir to the last version. I realized that I was using Qdir-32bit. When I installed 64bit version the parameter stoped working, but playing around with Qdir settings, specially in Extras Menu / Qdir as default file manager / Administrator… finally it worked again.


thank you Allekz