Listary has problems with Windows 10 version of SUBST command


#1

Hi, I rely heavily on the SUBST command to shorten the path name to a drive letter. For example, I shorten ‘c:\cloud\dropbox\d’ to ‘d:’ so that all my data files appear to be under drive d:. Listary handled this perfectly under Windows 7 and ‘saw’ this virtual folder ‘d:’ as an NTFS drive. This meant that new folders I accessed, e.g., ‘d:\doc’, showed up on Listary’s recent folders list. This no longer worked on a computer I upgraded from Windows 7 to Win 10 nor on my Win 10 laptop, which had Windows 10 installed from the beginning. Both Listary and the ability to use the SUBST command are very important to me. In fact, the problems with Listary and Win 10 made my delay my upgrade to Win 10 until the end of the free period. Any idea what is going on and how to fix it?
I’m running 64-bit Win 10 build 1511 & Listary 5.00.2381.


#2

Thanks for your feedback.

Do you mean that folders within your SUBST folder don’t show up in the recent menu? Do other normal folders show up correctly?


#3

I’m so sorry for my slow response; I just came back from vacation.
Yes that is exactly right.

If I save a file using the full path, e.g., C:\CLOUD\DROPBOX\D\test file.doc then that will show up as a Listary
recent folder.

My DOS devices reg entry is:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\DOS Devices]
“D:”=\??\C:\Cloud\Dropbox\D

By the, way I have also tried making this substitution via current user:
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run]
“D Drive”=“subst D: C:\Cloud\Dropbox\D”

If I save this file as “D:\test file.doc”, it won’t show up whether I have the HKLM or the HKCU setting. This
was not an issue in Windows 7 but is in Windows 10.

I rely on both Listary and my SUBST command for efficiency. I would love to be able to use both in Win10 as I did
in Win7.

Thanks for your help!

John


#4

Thanks for the information. I’ll check it.


#5

Just wondering if you’ve had a chance to check it yet?


#6

Yes. However Listary works correctly here:

Y: is created using subst. The real path of the file shown in the history menu is G:\Temp\hard_link_new_name.txt.

I’ve also tested saving files. Y: was listed correctly as the top one in the history menu after saving a file to it.


#7

Did you do this SUBST in a regular non-elevated Command
Prompt? I found a clue as to why Listary is not working for me although it
clearly works for you.

" The SUBST command works in Windows 7
but the substituted drive is only visible in the same privilege level.Running
your SUBST command in a NON-elevated command prompt should solve your
problem."

I confirmed this
below. My substituted Drive D appears in Windows Explorer and the non-elevated command
prompt but not the one with admin privileges!

Could this account
for the failure of Listary to reliably detect changes made to the virtual
drive? Does it matter where in the registry the SUBST information is
stored? I still haven’t figured out a solution though it might be that at each
boot, I’ll have to set the SUBST using both an elevated and non-elevated
prompt.


#8

That may not be the real cause.

I did more tests. I mapped T: in HKEY_LOCAL_MACHINE, and S: in HKEY_CURRENT_USER:

And then tested them in both non-elevated apps and elevated apps. And Listary worked perfectly every time:

So I really don’t know what’s wrong here. If you want to continue the investigation, I suggest that you try saving to the mapped drive using a simple app like Notepad first because the host app itself may have something to do with the issue.


#9

That’s very helpful. I’ve done my own changes and so far, Listary seems to be working. What I did was unclick Listary’s option ‘Run as Administrator’. I also changed my profile to a standard instead of an admin account. Now Listary is running as expected; not sure if I needed both changes. Could I ask you to do one thing with your mappings please? Could you open both a non-elevated and an elevated Command Prompt and see if your mappings show up with SUBST? I still suspect that there’s a permissions issue here.


#10

Running Listary as admin should be the real cause here, and it’s never recommended. There is no need to change your profile.

They don’t show up, same as in your tests.


#11

You are right. I turned off Listary as an admin and now it works perfectly on my two W10 computers where I’m using the SUBST command. Still, Microsoft changed something with W10; wasn’t a problem until my computer was upgraded from W7 to W10.

What is the purpose of the Listary admin mode? Would you mind putting a small comment in the contextual help telling users that this may lead to unexpected results and to avoid unless they have a good reason to use it?


#12

Sure, I’ll hide the option or add a warning.