Listary can't check for updates


#1

Hey there!

Hope you guys are fine! :smile: I have for months now the same problem, it is not really important but still:
Every time when I click on “Check for Updates” I get the following error message:

Listary can’t check for updates now, please try again later.

I also downloaded the full installer and tried it, but I got the same message and so I always have to check on the website if there is a new version or not! I mean there is a button called “Check for Updates” so it should work I guess! :wink:

Thank you for your comment! :smile:


#2

Nobody? Maybe it has to do with a Windows 10 service? Or anyone who has the same issue?

Thank you guys again for your help! :slight_smile:


#3

Never had same problem, network or your system issue?.
Now it’s Chinese new year so maybe the author is not online.
Listary doesn’t update often, instead of checking for update in that menu you can check here every few months:slight_smile:


#4

Hmmm … OK I will check it out again! Thanks for your info! :slight_smile: I was thinking about firewall settings etc. but I turned it off completely and it did not work! Thanks again!


#5

I guess I tried everything now.
EVERY other software can update automatically but Listary not. Strange. Is there a service needed like Windows Updates or something similar?

I deactivated my firewall
I checked all windows services
I checked permission to the roo-folder
AND MORE

Thank you for your help again!


#6

Can’t reproduce this.


#7

I’ll add more logging to help address this issue in the next release.


#8

Is a special service needed? Like the windows update service or a special port? Thank you guys! :slight_smile:


#9

There is no special service required, so it’s really strange that the update checker doesn’t work on some systems.


#10

Hmmm strange! At least I am not the only one! :slight_smile: Sounding like that! :slight_smile:


#11

Hi
Have had the issue for at least a few years now and I have tried everything Heisenberg tried
Running on three different computers, all running Windows 10 Pro 64 Bit
Had the same issue running Windows 7 also
Happens when I travel, at home, and at work (University network)
The only thing I haven’t tried (and I will shortly) is to add the program to my Bitdefender Whitelist
Channing, I would gladly test any beta releases you have to get this situation resolved

cheers

Stan


#12

It never worked for me and still doesn’t
Version 5.00.2664 under Windows 10 x64 Creators Update
There are no firewall issues or anything else.
It just says
Listary can’t check for updates now, please try adain later.


#13

@sllatesky @horst
I’ll try to implement the update checker in a new way. Hopefully it’ll fix this issue.