Fuzzy navigation now working very well. Even sample from tutorial is not working

I’m using current beta version.

I tried our Fuzzy Navigation example from your page:

I created the same folder structure as you in example and tried entering the same query (railsblog) but it did’t find anything useful. I even tried second examle with query (amus) and it failed to.

My custom example:
I tried and filed those queries:

  • raildata
  • projectsdata
  • railblogdata

And many many more

The one that worked was: rail\blog\data

But this is not what was shown in tutorial. Also if I don’t know whole directory tree structure it is useless.

It looks as if it fails as soon as I mix folder name with file name.

How should I use it?

Hi, fuzzy navigation has been updated to Search Path.

Search Path is more powerful and flexible. It allows you to type the target file name first as usual, and then append parent folder names only when necessary.

For example, if you want to find “FuzzyTest\RailsProjects\MyFirstBlog\data.txt”, you can start by typing “data.txt” as usual. If you get too many results, you can continue typing “data.txt rails” or “data.txt rails\blog” to narrow your search.

Thank you very much.
You should really update your tutorial website and rename “Fuzzy Search” in application options. It is really misleading.

I agree. The website will be completely redesigned soon.

“Fuzzy matching” in Listary Options has nothing to do with fuzzy navigation. It allows you to search for a file using multiple keywords without spaces (e.g. search for “VirtualBox.exe” by typing “vbox”). I suggest you turn it off if you don’t need it because you may get a lot more unexpected results.