6.3.0 beta is Live — New File Search Window, Updated File Search Engine, New User Documentation

The feature Open with in context menu is not working.

Listary Pro, Listary Pro … and now, V6.3.0.46 . Plz fix this big bug first

1 Like

May I know which file explorer you are showing in the gif? It looks like Windows 11 file explorer with qttabbar tabs, but i’m confused with the button bar below the navigation bar, besides the back arrow inside a blue circle. :thinking:

If it is the default file explorer, what software puts that button bar and highlights the back arrow?

Yes, the missing of Path Matching is really annoying…

1 Like

it’s win10 file explorer with qttabbar + classic shell/open shell (classic explorer toolbar) https://github.com/Open-Shell/Open-Shell-Menu.
hmm now that you mention it, I wonder if one of the tollbars gets in the way of type directly to search… it used to work fine using listary 5 and previous versions of 6, now it’s not working for me (on 2 different computers, win 10 and win11).
If you ever try, can you let me know if Type Directly works fine for you with listary 6.3.x + qttabbar ?

In my case “Type Directly” has always worked without problem since version 6 was released. My PC is running Windows 11 Pro on Dev channel and build 23536.


Oh, and I’m using the latest version of Listary so far with no problem.

When will path matching be available?

1 Like

Path matching is available in V6.3.0.51

V6.3.0.51 release

  • New: Add right-click menu support in File Search Window
  • New: Add path search support back to the new search engine
  • Improved: Optimize file search speed
  • Fixed: Fix support for WPS Sheets, Slides, PDF
  • Fixed: Fix other bugs of the new search engine
1 Like

Very useful update, as we now have the full context menu available.
What about an option to always show the extended File Search menu for the results.
Still missing the promised function to leave the File Search Window with ESC.

Windows 11 Home x64 Version 22H2 (OS Build 22621.2361)
Listary Pro

  • New: Explzh (a Japanese file archiver) integration (made by @wany-oh)

so an update about my issue with listary’s type directly to search not working :
it seems there’s a conflict with Qttabbar v2048 (http://qttabbar.wikidot.com/). not sure if it’s a specific setting but everything works fine if I uninstall Qttabbar.
I hope both programs can run together in the future.

1 Like

The problem is that Qttabbar may change the behavior of Windows Explorer.
Listary is not responsible for non-standard Explorer functions.
If you are out of luck, it may not be supported.
Also, Explorer under Windows 11 now has native tabs support.

Windows 11 Home x64 Version 22H2 (OS Build 22621.2361)
Listary Pro

thanks for the heads up.

Listary is not responsible for non-standard Explorer functions.

sure thing, however Listary 5 is working great with qttabbar though (including type directly to search), so I’m still hoping for a potential fix (ideally from listary since dev has resumed, whereas qttabbar seems on pause once again).
I ran into the issue when using listary 6.3.x (I believe it worked well with an earlier build of listary 6).

Also, Explorer under Windows 11 now has native tabs support.

the tabs feature can be replaced indeed, but qttabbar also brings quick previews on hover, file coloring by type/regex, quick folder browsing and many more useful features, so I hope both listary6 and qttabar are able to work in conjunction again (then vanilla explorer is almost a good replacement for an advanced explorer like xyplorer/dopus unless one need scripting).

for now I’m reverting to listary 5 + fluent search for daily use but I’ll keep testing new beta builds.


Same. Still on v5 because i need XYplorer support

1 Like

XYplorer is supported, I’m using it.
Only find as you type is currently not.
But using the double Ctrl while in XY it works fine and does almost the same.

Windows 11 Home x64 Version 22H2 (OS Build 22621.2428)
Listary Pro
XYplorer 25.00.0105

new update on my issue with type directly to search and QtTabBar v2048.

further investigation seem to show that enabling Compatible List View style in qttabbar v2048 will prevent type directly to search from working correctly in Listary 6.3.xx (although it works well with listary 5.x).

when the checkbox is diabled, type directly to search works fine (after explorer.exe is restarted).

I suppose ListView (legacy win2000-vista) is not supported anymore in latest Listary, can you confirm @Channing @xinyi ?
Would you consider bringing back support for that feature ? (it’s super useful in qttabbar as it allows custom color for files based on custom filters like file type, regex rule, size, etc.?..)
it makes it easier to distinguish executables for archives from media

nb: screenshot from win10 but it’s the same behavior in win11 22H2 on another pc
anyone know an alternative way to color files based on file type in explorer ? (I also use XYplorer that has the feature built-in, looking for an vanilla explorer.exe extension)

I don’t mean to spam the thread, but I really hope the ability to exit the File Search Window with ESC is added.

1 Like

Thank you for your hard work. I’ve noticed though, since the classic version 5, Listary no longer works on many dialogue boxes like the services one, If its possible to fix that, that would be great.
An example screenshot is included. I know it shows XP, but I’ve had the same results in 11.