Total Commander integration issue


#1

I have latest TC and latest Listary Pro. I open folder in Total Commander. Then I push Ctrl-Ctrl on a keyboard, enter “Notepad”, run Notepad, press Ctrl-O and then try to set Open File Dialog to my current TC folder. I press Ctrl-G for that but instead of current folder I found myself in My Computer folder.

Need help. Thank you.


#2

That works perfect here with Listary 5.00.2843 and TC 9.20b6
Did you try it with other folders in TC ?
Have you set the parameters for TC as Default filemanger, I have
/O /T /A “%1”


#3

horst, thing with default manager is made for different functionality as far as I know. It just opens a folder in this filemanager. And that’s working fine for me too.
What I want is to browse files in TC, then run some application, choose Open File dialog and synchronize Open File dialog folder with the current folder in TC. This works perfectly fine with Windows Explorer and does not work at all with TC for me.


#4

I guess you have to define TC as Default file manger because it works here without problems
using your steps everyday in many applications.
How should Listary know that it should follow the TC dir after a Ctrl-G
if you don’t configure it ?
In my case I want of course all folder operations also with TC
as using TC normaly means no Explorer please.
I have even set registry keys to make default folder operations in Windows with TC.


#5

Well, I did set TC as default file explorer in the first place. It doesn’t help.
Maybe it’s some Windows 10 issue? I have issues even with opening files in Windows explorer.


#6

Are you running TC or Listary as admin?


#7

I have Windows 10 x64 version 1803 (OS Build 17134.81)


#8

Channing,
I’m running TC as administrator. Not Listary.


#9

That may be the problem. Try to run TC as normal user.

I’ll let Listary support TC running as admin in the next version. Do NOT try to run Listary as admin to resolve this issue.


#10

It solved the problem! Now, with TC being run under normal privileges everything works fine.
Thank you!