Problem in Favorite Folders


#1

Hello Listary Support,
I’ve bought the Pro version of Listary mainly to replace Filebox Extender.

At first everthing seems to work well, but there is one problem that makes Listary more or less useless for me:

I have defined my Favorite Folders in Menu| Favorites.
If I doubleclick in the explorer Window, everything works fine and the selected folder is opened.
But, if I use doubleclick form a save-As folder (for example Acrobat Reader), the selected folder NOT always opened,
instead the Listary folder is opened most of the time.

And here is my question:
is it possible to define subfolders in Favorite Folders and stop Listary searching for subfolders when
the Favorite Folders are used?

This is how “Filebox Extender” works.

I use Win7-64 Bit and the Pro version of Listary.
Best Regards Siegfried


#2

Hi,

Are you running Listary or Acrobat Reader as administrator? Does this bug only happen for one specific favorite folder or all folders? And which version of Listary are you using?

Do you mean that you don’t want Listary to expand a favorite and show its contents in a submenu automatically?


#3

Hi, Channing,

Are you running Listary or Acrobat Reader as administrator? Does this bug only happen for one specific favorite folder or all folders? And which version of Listary are you using?

I’m working as Administrator, so this should be no problem.
My Listary Version is: 5.00.258

This bug happens for all the folders I am using, but not each time i try.
Like I’ve already mentioned, sometimes it works and sometimes it doesn’t.

And: Even if it works, I can see that the Open-Dialog first changes to the Listary Folder and then to the folder I’ve selected from the Favorites Menu.

Do you mean that you don’t want Listary to expand a favorite and show its contents in a submenu automatically?

Yes, that is what I meant.
In “Filebox Extender”, You can define subfolders in Favorites and you can select only those folders you have defined previously.

In my opinion, the favorites functionality should reduce the complexity of the Windows Explorer by only showing the subfolders defined in the Menu|Favorites.

In my Version of Listary, I cannot define subfolders like it is shown in this image:
http://discussion.listary.com/t/favorite-subfolders-not-listing-correctly-in-portable-v5-win-7/3044/3

Has the possibility of defining subfolders been removed from Listary?

Best Regards Siegfried


#4

Did you start Acrobat Reader or Listary manually as administrator? Is “Run as admin” checked in Listary Options - General?

It’s still there.


#5

Hi Channing, thanks for Your answers.
I’ll check your proposals next week.

Best Regards, Siegfried


#6

Hi Channing,
I found out how to use subfolders. :wink:

But my main problem still exists.
I’ve made some more tests, the problem occurs at least in the save-as-dialog of these programs:

  • irfanview Version 4.38
  • Acrobat Reader 11.0.6
  • notepad++ 6.8.5
  • upload-dialog of this forum!

Detailed Description of problem for notepad++:

  • start notepad++ with a text document
  • choose File|Save As
  • Doubleclick in the right free space, the Listary Favorites Dialog opens
  • Choose Favorite named “C:\tmp” which points to the existing folder C:\tmp

Now, each time I Doubleclick, and choose the favorite C:\tmp, alternately the folders
"C:\Program Files\Listary" and “C:\tmp” are opened.

As I tried to upload the image to the forum, even in the upload-dialog I have the same problem.

I can do this as often as I whish, same procedure.

Best regards Siegfried


#7

Notepad++ Open/Save dialogs are working fine here together with Listary.
NPP 7.3.3 x64
Listary 5.00.2664
Windows 10 Creators Update


#8

Hello Horst,
Could You please try the upload Dialog of this forum?

On my computer, when I try to use the upload dialog and use Listary Favorites, I can see that for a very short time,
that first the folder C:\Program Files\Listary is opened and then the target folder ist shown.

Most puzzling, at the moment, it is working.

best regards Siegfried


#9

No problem in the upload dialog.


#10

Unfortunately I still haven’t addressed the root cause of this bug. However I’ve already made some fundamental modifications in Listary 6. It should be more reliable.

P.S. If “Run as admin” is checked in Listary Options - General, uncheck it and restart Listary.


#11

Hello Channing,
as I was working under an administrator account anyway, the “Run as admin” was unchecked.

I’ve checked it, restarted Listary, same problem.
I’ve unchecked it, restarted Listary, same problem.

best regards Siegfried


#12

Hello Channing,
it is now 6 months since You told me that my problem should be fixed in Listary 6.
So, when will version 6 be available.

I’ve disabled Listary, because with the problem I’ve described above it it unusable for me.

best regards Siegfried


#13

Unfortunately I still can’t reproduce this bug.

I’m still working on Listary 6. I’ve already made some changes in the new version.They are likely to fix this but there is no guarantee.