Left/Right keys Banjaxed in Edit-control for 776

In what appears to be any Save-As dialog, if you click on the Filename line (so it has focus) and try to move the cursor to a different editing position within the text, Listary 776 interferes by activating itself. Typing/deleting text seems to work fine, just not moving the cursor.

Seems to apply to any Save-As modal for any application.

Hello Kilmatead,

Thanks for reporting the bug. Sorry that I can’t reproduce it on my test machines. Could you please paste some screenshots of how Listary activates itself?

Sorry that I can't reproduce it on my test machines.
Hmm - it survives a machine restart on mine (as well as a re-install) - and only appeared in the 776 build. Basically by "activates itself" I mean that when the cursor is in the Filename line happily editing text and you use the <> or <> "arrow" keys to move the cursor, Listary decides to steal focus and highlight between its first two menus ('Favourite" and "Recent" - but weirdly hitting <> again does not active the "Smart" menu - only the first two toggle).

If I click back into the Filename edit control, it definitely has focus and I can enter or delete text (curiously the <> and <> keys work as expected), but using either of the arrow keys again refocuses to Listary’s menus.

I don’t seem to have a backup of the previous build to verify that this is specific to 776 (for me, least). The only other version I have is the 776 beta, but this behaves the same (I only noticed it today). Is there a link for a “slightly” older version I might try?

That sounds more than weird to me because the toolbar doesn’t have the ability to handle any keystrokes (I haven’t implemented it yet). Here are the steps I used to reproduce the bug, please let me know if any step is wrong:

  1. I opened Notepad and typed something.
  2. Save the file (Ctrl + S) and the Save As dialog opened. The File name edit box should have input focus by default, so I didn’t do anything here.
  3. I used Left, Right and Backspace while editing the file name, it worked as expected.
Is there a link for a "slightly" older version I might try?
Here are some old versions. They are portable versions so you can unzip and test them easily without affecting your current configuration file.

http://www.listary.com/download/portable110823.zip
http://www.listary.com/download/portable111123.zip
http://www.listary.com/download/portable111207.zip

This is interesting - all three “portable” versions worked fine, which started me thinking maybe it was the configuration file itself that was causing this. So I nuked the Config.xml in the Roaming\Listary folder and started over (rebuilding settings, license key, etc). And now it seems to work fine.

I sent you an email containing a “Good” Config file and an “Evil” one (as well as a file detailing the differences between the two), so perhaps somewhere in there you can determine what happened - because if I put the Evil one back in, the problem returns.

Hello Kilmatead,

Please go to Listary Options - Keyboard and Mouse. You’ve set Left arrow and Right arrow as hot keys accidentally there.

Sorry for the inconvenience, I’ll disallow single keystrokes to be set as hot keys in the next version.

Hah, yeah, that was it alright - I guess there’s no accounting for user-mistakes. :slight_smile: I don’t recall doing that on purpose, but it definitely explains the behaviour. Thanks!