Listary opens .txt files with standard win. editor and not with the one(VIM) i set for this specific type(txt here)


#1

Hello

I use Vim 8.0 as standard editor for .txt file extensions but if i press ctrl x2 and type any text file name lets say test1.txt Listery opens test1.txt in a standard windows editor and not in Vim.
I tried Notepad++ as standard editor for .txt extensions and it worked.
The only solution i found to open .txt files in Vim is to set an Action “Edit with Vim” to Ctrl+E for example, but it is annoying. I just want to open .txt files in Vim with the Enter key.
What i also noticed is if i am in the folder of my text file and just start typing(without this global ctrl x2 search) “test1.txt” it actually opens my text file in Vim !
So there is a problem only if i open my file from this (Ctrl x2)_global_search_mode.

Thx


#2

Hi, how did you set Vim as the default .txt editor? Via right click menu, registry, or control panel?


#3

changed it with right click menu, also tried control panel it was already set to vim, didn’t find anything helpful in the registry under HKEY_CLASSES_ROOT / .txt
My reg .txt tree : OpenWithList>devenv.exe ,OpenWithProgids,PersisterHandler,ShellNew …
changed ItemName under HKEY_CLASSES_ROOT/.txt >ShellNew from
@%SystemRoot%\system32\notepad.exe,-470
to
C:\Vim\vim80\gvim.exe
didn’t help …


#4

Thanks for the info. I’ll test it.