Default File Manager Setting


I am using XYplorer as my default file manager. In trying to set this up I have placed C:\Program Files\XYplorer\XYplorer.exe in the path line/box, no quotes.  What should go in the Parameter line/box?
I’m not sure what it means by "…Use %1 in parameter for the path. Do not forget quotes."

I am more of a user than a coder and don’t have a real handle on variables.  I think that is what %1 is??

Listary is making opening and saving files so much easier now.  Wish I had found it a long time ago.
Thanks for a great program.


Hello kodyman,

Sorry to make you confused. It should be:

Path: C:\Program Files\XYplorer\XYplorer.exe
Parameter: "%1"

I’ll add documentation for this. Please don’t hesitate to
post here if you have any questions or suggestions!



Hello, just would like to suggest to be able to use a relative path pointing to the file manager. i tried …\total commander\totalcmd.exe, with and without quotes.

Great app and support (and the lifetime updates). i’m sorry i missed the bitsdujour promotion, i hope you do another one soon.

Thank you for this, been trying to spread the word, i’ve read nothing but good comments about your app, everywhere.



Thank you very much for your praise, Bruce!

Hello, just would like to suggest to be able to use a relative path pointing to the file manager. i tried ..\total commander\totalcmd.exe, with and without quotes.
This is already on my to-do list, it should be available in the next few versions.
i'm sorry i missed the bitsdujour promotion, i hope you do another one soon.
There is a limitation that the same software title can only be promoted on bitsdujour again after 4-6 months. I'll definitely rerun the promotion as soon as possible.


Thanks for the reply! I actually found out about your software from your thread over at the total commander forum.

I wish you success in your project. Cheers!


I have started using Listary (3.51) and my default file manager is xplorer2.

When I am in Firefox, for example, and I bring up the Listary popup, then select a Favorite folder, Listary opens that folder in Windows Explorer, not xplorer2. I would like to set xplorer2 as Listary’s default file manager.

Under Applications in Options I can see xplorer2 listed along with other apps as being Enabled for Listary, but I cannot see any way of making it the default, so all jumps to folders will open them in xplorer2. Can this be done? I read the earlier posts here and in other threads but how to do it is still not clear to me. Thanks for your help.



Hello, please follow these steps:

  1. Open Listary Options and switch to the General (the first) tab.
  2. Click the blue “Default File Manager >>”.
  3. Set the text boxes like this:
    Path: C:\Program Files\XYplorer\XYplorer.exe
    Parameter: "%1"

    Change Path to the correct path of your xplorer2 executable.


Thanks a lot Channing! It works now - I missed the blue link.
Note that even though “Program Files” contains a space, there is no need to enclose the Path to your selected file manager in double quotes. However, it IS necessary to enclose the %1 parameter in double quotes.


Hello! Agreed Listary is the best!

I have a similar question - using Listary in portable format, the path to the file manager - a portable XYplorer install varies of different computer depending on the USB drive letter.

Has this relative path option been added so I can use “…” to go “up” a directory from the “Listary.exe” folder?



I think so. You can give it a try.



I’ve tried many times from Listary folder to go up one level to XYplorer.exe such as:
"…\XYplorer Portable\XYplorer.exe"

  • \Listary Portable\
  • \XYplorer Portable\

Folder above with .exe’s sit side by side, so the above path should work? Unfortunately XYplorer.exe doesn’t open when accessing a folder in Listary. :disappointed:

This feature would also be useful for subfolders of shortcuts and URLS to access via Listary and favourites, etc. All with the intent of having it work consistently and as per my settings on any computer (drive letter) via USB.

Any suggestions?

Thanks! :slight_smile:


Make sure Path doesn’t contain quotes and Parameter does.


Unfortunately I must be doing something wrong still. I’ve uploaded screens of what I’m doing. In addition to the settings you’ve suggested, Listary (.exe) is in the folder 'Listary Portable" as pictured, whilst XYplorer.exe is in the “XYplorer Portable” folder… side by side.

Thanks for your continued help.


Please confirm that there is not another folder level in Listary Portable and XYplorer Portable. I just set up exactly the same environment as you described and tested it, it worked as expected.


No, there isn’t another folder level.

\Listary Portable\listary.exe
\XYplorer Portable\XYplorer.exe

Maybe my desired outcome/intent is wrong? I assume that this setting opens the file manager (as desired above) when selecting a folder in Listary after pressing CTRL+CTRL, “search term” and the ENTER on a folder. Am I wrong?

Right now when I select any folder within Listary, nothing happens/opens.

Thank you.

Edit - I switched the setting back to ‘Windows Explorer’ and it worked fine (opening in Windows Explorer of course).


You’re right.

I suggest you set the absolute path of XYplorer first, make XYplorer work as expected, then edit the path to a relative form. Maybe it’s easy to see what’s wrong in this way.


Thank you for your help, I will continue to persist!

As a result - proud paid “Pro” user as of today.

Thank you for your hard work!